[Airship-discuss] Airship-in-a-bottle (AIAB) deployment question

calvin whole calvinwhole at gmail.com
Wed May 22 08:51:09 UTC 2019


We have tried to deploy AIAB by both methods described in the below
available info from Airship site.

Both methods failed to complete the deployment process and the result is
also different.
1. With the "./airship-in-a-bottle.sh" method, it stuck in "mariadb not
ready" state.

2. With the "vagrant up" method, we tried the libvirt and virtualbox
With virtualbox provider "sometimes" we can reach the "Genesis complete"
step, but the Openstack step still failed to complete.
With libvirt provider we always stuck in "mariadb not ready" or

So it seems to us that the execution output is sensitive to the
virtualization environment.
For this reason, the documentation below may need to provide more details
about the required environment setup.

Can someone provide us a more detailed info about AIAB execution
requirement ?

Or, do Airship have a QA group that we can contact for help?

Many thanks,


To get started, run the following in a fresh Ubuntu 16.04 VM (minimum
4vCPU/20GB RAM/32GB disk). This will deploy Airship and Openstack Helm

sudo -i
mkdir -p /root/deploy && cd "$_"
git clone https://git.openstack.org/openstack/airship-in-a-bottle
cd /root/deploy/airship-in-a-bottle/manifests/dev_single_node

Or, alternatively, if you have Vagrant installed, just run the following
(only libvirt/kvm hypervisor is tested, but vagrant box supports VMware
Desktop/Workstation/Fusion, Parallels, and Hyper-V):

curl -O https://git.airshipit.org/cgit/airship-in-a-bottle/plain/Vagrantfile
vagrant up
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.airshipit.org/pipermail/airship-discuss/attachments/20190522/20eef55c/attachment.html>

More information about the Airship-discuss mailing list