[Airship-discuss] Airship-in-a-bottle (AIAB) deployment question

MCEUEN, MATT MM9745 at att.com
Wed May 22 13:52:55 UTC 2019

Hi Calvin,

Have you taken a look for the root cause of why mariadb is not ready, e.g. as Roman suggested, running `kubectl -n ucp describe pod mariadb-server-0` on the genenesis node?

Are you running at the minimum 20GB or RAM?  I’m wondering whether airship-in-a-bottle has outgrown that.  If you’re able to run with additional resources it would be good to see if that changes the result.

We don’t have a different QA mailing list, but you’re welcome to join the #airshipit channel on Freenode IRC as well and share logs / ask questions there!


From: calvin whole <calvinwhole at gmail.com>
Sent: Wednesday, May 22, 2019 3:51 AM
To: airship-discuss at lists.airshipit.org; calvin whole <calvinwhole at gmail.com>; Roman Gorshunov <paye600 at gmail.com>
Subject: [Airship-discuss] Airship-in-a-bottle (AIAB) deployment question


We have tried to deploy AIAB by both methods described in the below available info from Airship site.

Both methods failed to complete the deployment process and the result is also different.
1. With the "./airship-in-a-bottle.sh" method, it stuck in "mariadb not ready" state.

2. With the "vagrant up" method, we tried the libvirt and virtualbox providers.
With virtualbox provider "sometimes" we can reach the "Genesis complete" step, but the Openstack step still failed to complete.
With libvirt provider we always stuck in "mariadb not ready" or "deckhand-db-init".

So it seems to us that the execution output is sensitive to the virtualization environment.
For this reason, the documentation below may need to provide more details about the required environment setup.

Can someone provide us a more detailed info about AIAB execution requirement ?

Or, do Airship have a QA group that we can contact for help?

Many thanks,


To get started, run the following in a fresh Ubuntu 16.04 VM (minimum 4vCPU/20GB RAM/32GB disk). This will deploy Airship and Openstack Helm (OSH):

sudo -i

mkdir -p /root/deploy && cd "$_"

git clone https://git.openstack.org/openstack/airship-in-a-bottle<https://urldefense.proofpoint.com/v2/url?u=http-3A__git.openstack.org_openstack_airship-2Din-2Da-2Dbottle&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=_C5hC_103uW491yNPPpNmA&m=qGH7CH6vJpqo2zaDk0Dy-jyJ-D4Mp9s_IURAu8KXIjQ&s=d9jeVVrvEr_lhTLcsBqIWqiP5hYeZ2jLW8-wQI1f78U&e=>

cd /root/deploy/airship-in-a-bottle/manifests/dev_single_node


Or, alternatively, if you have Vagrant installed, just run the following (only libvirt/kvm hypervisor is tested, but vagrant box supports VMware Desktop/Workstation/Fusion, Parallels, and Hyper-V):

curl -O https://git.airshipit.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__t.airshipit.org&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=_C5hC_103uW491yNPPpNmA&m=qGH7CH6vJpqo2zaDk0Dy-jyJ-D4Mp9s_IURAu8KXIjQ&s=sNKkg6eRk5lZROaz1CJncbtvoUjbndvnPeUN-_CNQnw&e=>/cgit/airship-in-a-bottle/plain/Vagrantfile

vagrant up
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.airshipit.org/pipermail/airship-discuss/attachments/20190522/4cecc440/attachment-0001.html>

More information about the Airship-discuss mailing list